New to phaser


I am really new into this. I am trying to understand how this works…

I am following these instructions: Getting Started with Phaser 3: Part 1 - Introduction - Learn - Phaser

My operating system is Windows 7. I have Sublime and downloaded the file mongoose.exe which I have run.
Then I downloaded the zip file with Phaser, and unzipped it in My Documents.

I have created the index.html file as suggested in step 5, and run it in my local URL. The effect was the expected, the word Pahser moving through the screen on Firefox browser.

I am trying now to follow this tutorial Making your first Phaser 3 game: Please select a language - Learn - Phaser
But nothing happens when I try to open the part3.html file…

Maybe I should put the zip file somewhere else? Where? Or I missed some installation step?

Regards from Argentina

How do you open the file?

It should be something like: http://localhost:8080/part3.html


I did this and now it works: I deleted the index file in the mongoose directory, and clicked in “Go to local URL” in the mongoose menu. In Firefox showed up a list of files in such directory, and then clicked on the file I want. And it worked. It does not work when I execute from the folder en C:/mongoose/.

Should I keep the unzipped folder in MyDocuments? Or where should I put it?

I think I am not using these files in the example… Because in the line 6 of the code it says:

I suppose this line is the imoprtation of the Phaser library, am I right? So I should somehow import it from my own computer instead…

Best regards!

You cannot execute an html file. You need to browse to it.
So if mongoose uses port 8000, go to http://localhost:8000
This will show you the files that are under the ‘shared directory’ that mongoose is serving.
If you want to go directly to part4.html, go to http://localhost:8000/part4.html
You should unzip files to c:\mongoose (if you put mongoose.exe there). That is its default ‘shared directory’. It knows nothing about MyDocuments.

<script src="//"></script>
means that you get Phaser online. You should use a newer version (3.54.0).
You can download that version if you like, and then change line 6 to
<script src="./phaser.js"></script>.
But usually it’s easier to just use the online (latest) version.