Files not found on server, but on local Wamp server


#1

Hey Guys,
I finally finished my phaser 2 game. And I am trying to run it on a github pages “server”.
But a lot of files are not found if I run it on pages. I am getting this error:

GET: assets/images/systemmessage.png:1 https://myUser.github.io/assets/images/systemmessage.png 404
Phaser.Loader - image[systemMessage]: error loading asset from URL assets/images/systemmessage.png

I am a bit confused why. Everything works fine on my local wamp server.
And I am loading other png files from the same directory and that works.
Can you tell me why it loads some pngs and some others not?

dialogWheelhimself is missing, traitsBox is loaded. Both in the same state, in the preload function.
this.load.image(‘dialogWheelhimself’, ‘assets/images/dialogwheelhimself.png’)
this.load.image(‘traitsBox’, ‘assets/images/traits.png’);

Many thanks,
Colin


#2

I fixed the issue…
file name: dialogWheel.png
in my code: this.load.image(‘dialogWheel’, ‘assets/images/dialogwheel.png’)

Thats no problem if I run it on my local server but on a webserver it causes that issue.

Thanks


#3

Can you add [FIXED] in the title please