geting this error on my preload and it crashes my game

its from the phaser.js something to do with this this function


I’ve tried an older version and newer version of phaser and still get this error.

Anyone had this happen? Or any advice on how to debug it would be greatly appreciated.

Can you post the whole offending code, and point out what line of your code is seen in the stacktrace?

Solved it, basically in my preloader i loaded a png with camel casing, but the actual file name was all lower case, browsers seem to not care about this, but if you try it on a simulator it wont be able to match the file. This took me far too long to find since I assumed it was an audio file giving me the issue… but a problem solved is a problem solved.

Very interesting. Because my very first thought was that the file wasn’t at the path expected, but no, that would be a 404 Not Found error. I guess that makes sense, though. The world of HTTP doesn’t care about casing but Javascript does. Maybe it would make sense for Phaser to to give some kind of warning if it detects that this has happened. Because that is a pretty confusing error.