Help needed - supporting people to learn morse code - isolated due to covid-19

Hi all. I’m an Occupational Therapist (a healthcare worker) and I focus on supporting people who have severe and complex disabilities who can’t communicate - to speak. We do this using technology (think Stephen Hawking). We are working with a number of individuals who are blind (as well as physically disabled and can’t speak) to learn to use morse code. Short story: Its super-efficient. To do this we have taken a phaser game that was supported by Google to teach morse code - and put sounds on it. Morse is fantastic - but teaching someone, particularly someone who has now isolated from the world thanks to sars-cov-2, is really difficult. We are now needing some support fix a round of issues as the app was really designed to be run originally on android - and without these sounds…

Back story behind the whole project: Google did a great job - but it really was a one-off thing and not a lot more work has been done on this. Hence us trying to take up the reigns.

Right now I’m trying to support people remotely through this pandemic and help people communicate as much as possible - but getting this off the ground would really help a few people currently isolated in care homes and hospitals.

If you fancy helping out in any way - your help would be tots appreciated!



How about put the game over a webview on android? This will open the possibilities to old phones. I will take a look at this project on the night.

It hasn’t huge amounts of testing on android. Thanks for taking the time to look into it! One thing to be aware of - it’s really designed to work with an external keyboard - and two keys (dot and dash). We ideally want to be able to create a configuration screen to allow someone to set these keys ( see the issues linked in the gist). Do need to give a way of having dot / dash working as onscreen buttons too though. The original code was doing that but was a bit messy. Thanks again.

I will help you with code, but I only can do this tomorrow.
Write all you need on the backlog relative to code of the game that I’m go do what I can do.
I like project likes this.
Modify the backlog and I will work at some issues too.

Thanks a million! I’ve updated it a bit - just nudge me if any of it doesn’t make sense. Woo!

Only a update. I’m working on the project, I have get some bugs because of the structure of the code, but I will solve part this in the time.

The new update ‘broke’ the layout of the game on my desktop.

This message about before is’nt show, now it not close.

Thank you. Take your time! Your help is really appreciated. I do realise the project is a bit weird in places… It took me a while to figure out how (and why) it was constructed like it was.

Just a FYI. There was quite a bit of traffic on the upstream project this weekend. Due to this post on reddit. Some interesting comments that are fixes in our fork.

I was a US Embassy Telecommunication Officer certified in Morse. How can I help.

Ok man, I’m slow because I’m worried about coronavirus in my city. So, I stopped to programming for while. I will follow your project from github.
Sorry for the delay at contribute to the project.

Awesome! @cpusam got a bit stuck - I’m not sure if there is any boys you can work on. ?
In the meantime - One thing we are kind of stuck on is giving the user some feedback how well they are doing. In typical morse it’s all about wpm. In this version - where it’s not using a morse key and timing is achieved by 2 keys - how you do that is not so clear. Have a read of this discussion - - any thoughts and ideas much appreciated.

Ah thèse times are crazy. Don’t apologise! I’m visiting patients at the moment and doing some support visits when their communication equipment and methods are breaking down in hospital - something that’s vital when they are being separated from family etc but a lot of the time it’s support calls and giving them something like morse practice whilst being holed up. It’s a bizarre time - and a scary one. Any help you can offer is super appreciated!

I’ve tried the link multiple times on my pixel 3a on chrome. All the buttons (help, sound toggle) all work. But I always see tap to start. No matter how much or where I tap nothing happens.

Hmmm - I must admit I haven’t tried on mobile. I dare say thats a hangover from the old project that was designed to be an app on android… Need to put that on the backlog

1 Like

Ive created an issue queue from the backlog (didn’t know I could switch on issues for a fork!) - if you are working on any one issue please let me know. Thanks!